UserAdminPanel - only indirect access (and no Dashboard)

Views 29
Sweets 0
Images 0

6 days ago Topic
pebwindkraft
Member
Total Posts: 6
Joined: May 03, 2019
Posted: May 13, 2019 @ 04:16 PM
So after having posted the previous topic on plain installation, I thought I open a second one for access within the app. It is similiar to the previous item 54 in the forum (successfully logged in but still "not logged in"...). The direct access to the admin panel would not work, when clicking on the top right "my user ID" and then AdminPanel. It would give me this reply:
Code
There is an error on this page.
Error has been logged and Admin has been notified. Please try again later.
However, if I click on "members" in the UAP HOME page, then chose the first user (which is admin), and below the member's picture chose "Admin - Edit User", then I am in the ADMIN AREA. Clicking on Dashboard would lead to the same error, but all other items on the left side provide me with the corresponding screens. I have defined
Code
ServerName "oslhpeb840.my.domain"
DocumentRoot "/srv/www/htdocs"
ServerAdmin root@localhost
in my default http file (no virtual host), and the servername is in /etc/hosts as 127.0.0.1. The same happens when I use a fixed IP address of my network card for the hostname in /etc/hosts (192.168.x.y). And also after deleting all cookies, same behaviour. Observations: nothing in root's mailbox... (POSTFIX is running, mail from user to root at command line works). So looking at the logfile(s): nothing in the apache logs, and no error-log file in the UAP directory structure. Puzzled.
Reply By: DaVaR
6 days ago #1
DaVaR
Administrator
Total Posts: 120
Joined: July 14, 2015
Posted: May 13, 2019 @ 08:55 PM
Any time you get the error message:
Quote
There is an error on this page. Error has been logged and Admin has been notified. Please try again later.
The first place you want to look is in your /errors/php-error.log Most likely it is something simple. When you get a chance please post the message stored in that file at the time of error. The error should look similar to this:
Code
           ---------

Exception information:

           Date: May 09, 2019 19:02PM

           Message: syntax error, unexpected 'save_post' (T_STRING)

           Code: 0

           File: /var/www/websites/uap4demo.userapplepie.com/app/Plugins/Forum/Controllers/Forum.php

           Line: 585

           Stack trace:

           #0 /var/www/websites/uap4demo.userapplepie.com/vendor/composer/ClassLoader.php(322): Composer\Autoload\includeFile('/var/www/websit...')
#1 [internal function]: Composer\Autoload\ClassLoader->loadClass('App\\Plugins\\For...')
#2 [internal function]: spl_autoload_call('App\\Plugins\\For...')
#3 /var/www/websites/uap4demo.userapplepie.com/app/System/Router.php(31): class_exists('App\\Plugins\\For...')
#4 /var/www/websites/uap4demo.userapplepie.com/public/index.php(45): App\System\Router->__construct()
#5 {main}

           ---------

Signature
MmMmmm... Apple Pie!
Reply By: pebwindkraft
4 days ago #2
pebwindkraft
Member
Total Posts: 6
Joined: May 03, 2019
Posted: May 15, 2019 @ 11:14 PM
I see ... I am partially there. After several re-installations of default servers or virtual machines, I ran into the issue of the reCAPTCHA. As we had chatted already... Here the line from php-error.log
Code
2019-05-14 11:21AM - file_get_contents(): Unable to find the wrapper "https" - did you forget to enable it when you configured PHP? in /srv/www/vhosts/avh-001.my.domain/vendor/google/recaptcha/src/ReCaptcha/RequestMethod/Post.php on line 68
I got this fixed by uncommenting the openssl line in php.ini. Also tried the GITHUB files... it would show exactly the same behaviour. No direct access to admin page via top right menu, but when I go through the member link, then I get access. When uncommented openssl in php.ini, it would work. For completness to the request at the very top, I setup again the system without openssl (line is commented out), the error message in php-error.log would show similiar error:
Code
2019-05-16 1:50AM - get_headers(): Unable to find the wrapper "https" - did you forget to enable it when you configured PHP? in /srv/www/htdocs/app/Controllers/AdminPanel.php on line 66

2019-05-16 1:51AM - get_headers(): Unable to find the wrapper "https" - did you forget to enable it when you configured PHP? in /srv/www/htdocs/app/Controllers/AdminPanel.php on line 66
It was only the Dashboard, which is not shown. All other links show corresponding pages. Anyhow, with an updated php.ini it works :-) btw: nice to have the icons left to the "submit reply" fields, so BB codes can easily be used.
Forum Permissions
You cannot post in this forum.
You cannot moderate this forum.
You cannot administrate this forum.
Search Forums
Forum Recent Posts